Issues with DNS resolution
Incident Report for The Grid
Resolved
Services appear to have resumed for our US users.
Posted 5 months ago. Oct 21, 2016 - 22:29 UTC
Update
The issue appears to mainly affect US users. We hope the DNS services resume there soon.
Posted 5 months ago. Oct 21, 2016 - 19:40 UTC
Monitoring
Due to the currently ongoing DDoS attack on DNS infrastructure some of our services are hard to reach.

http://arstechnica.com/security/2016/10/dos-attack-on-major-dns-provider-brings-internet-to-morning-crawl/
Posted 5 months ago. Oct 21, 2016 - 18:28 UTC