URL sharing not working
Incident Report for The Grid
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 23, 2017 - 13:44 UTC
Identified
There is a temporary disruption in sharing content via URLs to The Grid. We're working on resolving the issue.
Posted about 1 month ago. Mar 23, 2017 - 09:20 UTC